La formule conditionnelle et formule conditionnelle imbriquée sous Excel


Dans cette FAQ, nous allons faire un petit tour d'horizon et explications de la formule conditionnelle et formule conditionnelle imbriquée sous Excel.

Pour commencer, double cliquez sur l'icône Excel sur le bureau ou par le menu Demarrer => Tous les programmes.

Dans notre exemple de feuille, nous allons ici donner une note d'évaluation en fonction de la moyenne de l'élève, toutes les notes inférieures à 10 auront un B et toutes les notes supérieures à 10 auront un A. Pour cela, nous allons nous servir de la formule conditionnelle SI.

Positionnez-vous sur la cellule du résultat puis tapez =SI(E4>10;"A";"B") et tapez entrée au clavier.

Explication : =SI(test_logique;[valeur_si_vrai];[valeur_si_faux]
=SI(le contenu de la cellule E4 est supérieur à 10 (;alors) [ mettre ceci "A"] (;sinon) [mettre cela"B"])
et nous fermons la parenthèse ouverte du début.

Remarque : le texte de valeur_si_vrai et valeur_si_faux doit être mis entre doubles guillemets "" pour du texte, non pour des chiffres.


formule conditionnelle sur Excel

La formule étant entrée pour la ligne 4, pour Michel, nous allons la reproduire pour les autres :

Cliquer sur la cellule F4 (dans notre exemple) puis positionnez-vous en bas à droite de la cellule sur le carré noir , votre curseur se transforme en croix noire, maintenez le bouton gauche de la souris enfoncé puis faites glisser la poignée jusqu'à la cellule F8 puis relâchez le bouton gauche.

formule conditionnelle condition sur Excel


Conditions imbriquées : même chose que plus haut, mais là nous allons donner un "A" pour les élèves qui ont plus de 15, un B pour ceux qui ont plus de 10 et un C pour tous ceux qui ont en dessous de10. Pour cela nous allons employer la condition imbriquée.

Positionnez-vous sur la cellule du résultat puis tapez =SI(E4>15;"A";SI(E4<10;"C";"B";)) et tapez entrée au clavier.

Explication : =SI(1er test logique E4 supérieur à 15 ; alors mette "A" on sépare le 2e test logique par un ; SI( E4 inférieur à 10 ; alors, mettre "C" ; sinon aucune des 2 conditions n'est remplie donc mettre "B")) 2 parenthèses ouvertes à fermer.

formule conditionnelle test condition sur Excel


La formule étant entrée pour la ligne 4 pour donc Michel nous allons la reproduire pour les autres.

Cliquer sur la cellule F4 (dans notre exemple) puis positionner vous en bas à droite de la cellule sur le carré noir , votre curseur se transforme en croix noire, maintenez le bouton gauche de la souris enfoncé puis faites glisser la poignée jusqu'à la cellule F8 relâchez.

formule conditionnelle avec exemples sur Excel


Commencez les conditions avec le test logique du plus grand au plus petit, un autre exemple ci-dessous avec 3 tests logiques donc 4 conditions.

À vos tableurs pour reproduire l'exercice !






Attention
Les réponses ne vous sont données qu'à titre indicatif et nous ne pourrions en aucuns cas être tenus pour responsable de problèmes ou pannes survenants sur votre matériel.



Date de création de la FAQ :  24.06.2010

© www.tutoriauxpc.com (2001-2021)