Catégorie Astuces logiciels



La formule conditionnelle et formule conditionnelle imbriquée sous Excel

Petit tour d'horizon et explications de la formule conditionnelle et formule conditionnelle imbriquée sous Excel.

Double cliquer sur l'icone Excel sur le bureau ou par le menu Demarrer => Tous les programmes.

Nous allons ici donner une note d'évaluation en fonction de la moyenne de l'éléve, toutes les notes inférieurs à 10 auront un B et toutes les notes supérieurs à 10 auront un A, donc nous allons nous servir de la formule conditionnelle SI :

Positionnez-vous sur la cellule du resultat puis tapez =SI(E4>10;"A";"B") et tapez entrée au clavier

Explication : =SI(test_logique;[valeur_si_vrai];[valeur_si_faux]
=SI(le contenu de la cellule E4 est supérieur à 10 (;alors) [ mettre ceci "A"] (;sinon) [mettre cela"B"])
et nous fermons la parenthèse ouverte du début.

Remarque : le texte de valeur_si_vrai et valeur_si_faux doit être mis entre doubles guillemets "" pour du texte, non pour des chiffres.


La formule étant entrée pour la ligne 4 pour Michel nous allons la reproduire pour les autres :
Cliquer sur la cellule F4 (dans notre exemple) puis positionnez-vous en bas à droite de la cellule sur le carré noir , votre curseur se transforme en croix noir , maintenez le bouton gauche de la souris enfoncé puis faites glisser la poignée jusqu'à la cellule F8 puis relachez le bouton gauche .


Conditions imbriquées : Même chose que plus haut mais là nous allons donner un "A" pour les éléves qui ont plus de 15, un B pour ceux qui ont plus de 10 et un C pour tous ceux qui ont en dessous de10. Pour cela nous allons employer la condition imbriquée :
Positionnez vous sur la cellule du resultat puis tapez =SI(E4>15;"A";SI(E4<10;"C";"B";)) et tapez entrée au clavier

Explication : =SI(1er test logique E4 supérieur à 15 ; alors mettte "A" on sépare le 2éme test logique par un ; SI( E4 inférieur à 10 ; alors mettre "C" ; sinon aucune des 2 conditions n'est remplies donc mettre "B")) 2 parenthèses ouvertes à fermer.




La formule étant entrée pour la ligne 4 pour donc Michel nous allons la reproduire pour les autres :
Cliquer sur la cellule F4 (dans notre exemple) puis positionner vous en bas à droite de la cellule sur le carré noir , votre curseur se transforme en croix noir , maintenez le bouton gauche de la souris enfoncé puis faites glisser la poignée jusqu'à la cellule F8 relachez .


Commencez les conditions avec le test logique du plus grand au plus petit, un autre exemple ci dessous avec 3 tests logiques donc 4 conditions.

A vos tableur pour reproduire l'exercice !

Attention: Les réponses ne vous sont données qu'à titre indicatif et nous ne pourrions en aucuns cas être tenus pour responsable de problèmes ou pannes survenants sur votre matériel.
Pour Imprimer cette Q/R
  • Auteur : tutoriauxpc
  • Publié : 24.06.2010
  • Lu : 24454 fois